FAQ : IDEAL Administration | IDEAL Dispatch | IDEAL Remote | IDEAL Migration | IDEAL Alerter | IDEAL Secure


FAQ : IDEAL Remote

Schnelle und sichere Fernsteuerung für Windows, Mac OS X und Linux

General

Is your software compatible with Windows 2008 / 2012 / 2016 / 2019 Server ?

I envisage to install a new Windows 2019 Server at the office.

Is your software compatible with Windows 2019 Server?

All our software are compatible with Windows 2008 / 2012 / 2016 / 2019 Servers.

READ: Is your software compatible with 64 bits Operating Systems?

Also concerns the following software:
IDEAL Administration | IDEAL Migration | IDEAL Dispatch | IDEAL Secure | IDEAL Alerter
Last modification: 26/08/2019

Previous
   
Next

Back to the list of FAQs

 


IDEAL Remote 14.64
Testen Sie unsere
kostenlose 30-tägige
Zurück zum Anfang